読者です 読者をやめる 読者になる 読者になる

PHP 5.3.3 でも max_input_vars は有効

Warning: Unknown: Input variables exceeded 1000.
To increase the limit change max_input_vars in php.ini. in Unknown on line ~

なんてエラーが出てる…。

http://php.net/manual/ja/info.configuration.php
PHP 5.3.9 以降で有効、って書いてあるので油断してたら、

PHP 5.3.3 でも有効らしい。
(phpinfo()で確認したら、しっかりデフォルト値の1000って出てきた。)

なんだよもー!!

CentOSyumですが、hashdos対策でアップデートされたのかな?
マニュアル表記のミスなのか、yumのほうなのか…。
PHPメーリングリストじゃ過去ログ検索できないのか、namazu.cgiが NotFoundになる。

とりあえず
max_input_vars = 10000 あたりに設定して様子みます。